Integrating HCL OneTest Embedded Studio with Microsoft Visual Studio

OneTest Embedded provides a special setup tool to configure runtime analysis tools with Microsoft Visual Studio 6.0.

Note   Integration with Microsoft Visual Studio is only available with the Windows version of HCL OneTest Embedded Studio.

Installation

Both OneTest Embedded and Microsoft Visual Studio must be installed on the same machine.

To install the Microsoft Visual Studio 6.0 plug-in:

  1. From the Windows Start menu, select Programs > HCL Software > HCL Software, HCL OneTest Embedded, Tools and HCL OneTest Embedded Plug-in for Microsoft Visual Studio Install to add the new menu items to Microsoft Visual Studio

To uninstall the plug-in:

  1. From the Windows Start menu, select Programs > HCL Software > HCL Software, HCL OneTest Embedded, Tools and HCL OneTest Embedded Plug-in for Microsoft Visual Studio Uninstall to remove the plug-in from Microsoft Visual Studio.

To install the Microsoft Visual Studio .NET plug-in:

  1. From the Windows Start menu, select All Programs > HCL Software > HCL OneTest Embedded > Tools > TDP Editor.

  2. In the TDP Editor, select File > Open and open cvisual7.xdp located in the <install_directory>/ targets/xml directory.

  3. Under Basic Settings > For All, set the INSTALL_PLUGIN key to TRUE.

  4. Save cvisual7.xdp and close the TDP Editor.

To uninstall the plug-in:

  1. From the Windows Start menu, select All Programs > HCL Software > HCL OneTest Embedded > Tools > TDP Editor.

  2. In the TDP Editor, select File > Open and open cvisual7.xdp located in the <install_directory>/ targets/xml directory.

  3. Under Basic Settings > For All, set the INSTALL_PLUGIN key to FALSE.

  4. Save cvisual7.xdp and close the TDP Editor.

Configuration

The HCL OneTest Embedded setup for Microsoft Visual Studio tool allows you to set up and activate coverage types and instrumentation options for HCL OneTest Embedded Studio runtime analysis features, without leaving Microsoft Visual Studio.

To run the product Setup for Microsoft Visual Studio:

In Microsoft Visual Studio, two new items are added to the Tools menu:

The following commands are available:

Code Coverage Instrumentation Options

See About Code Coverage and the sections about coverage types.

Other Options

Related Topics

Using Runtime Analysis Features | Importing Files from a Microsoft Visual Studio Project file |  |Working with Rational ClearQuestWorking with Rational ClearCase