Verifying the Success of Your Repairs

As you have now learned, tests always need to be rerun and reports should always be rechecked.

To check that defects have been resolved:

  1. From the View menu, select Other Windows and Project Window.

  2. From the Window menu, select Close All.

  3. In the Project Browser tab on the right-hand side of the screen, left-click the PhoneNumber test node and then select the Build toolbar button.

  4. The test has finished executing when the green execution light on the lower-right of the UI stops flashing.

  5. From the File menu, select Save Project.

  6. Expand the Runtime Trace viewer that appeared during the test run.

By looking at the Runtime Trace Viewer, you will find that the unexpected exception has disappeared and is now replaced with a call to the PhoneNumber destructor. One more defect has been eliminated. That was one defect you would not have caught without the assistance of the runtime tracing feature of Test RealTime.