Runtime Analysis exercises

The following exercises will walk you through a typical use case involving the four runtime analysis features of Test RealTime to which you have just been introduced. Pay close attention not only to the capabilities of these features but also to how they are used. The better you understand these features, the more quickly you will be able to adopt them within your own development process.

If you have never run this tutorial before, make sure your machine has a temporary folder in which you can store the test project you will be creating. For the tutorial, it is assumed that the test project will be stored in a folder called tmp.

If you have run this tutorial before, do not forget to undo the source file edits you made the last time you ran through it. The following files are modified during the tutorial:

If you intend to use Microsoft Visual C/C++, but installed it after installing the product you will need to update the associated TDP. If the product was installed after Microsoft Visual C/C++ then no changes need to be made.
See this page if you need to update the TDP.

To run the tutorial without Microsoft Visual Studio:

  1. For Windows: install a recommended GNU C and C++ compiler - see Installing the GNU Compiler for instructions. For Linux: use the native C and C++ compiler already installed on your machine

  2. During installation of the product:

To make a different compiler available for the product:

  1. From the Tools menu, select Target Deployment Port Editor and Start

  2. In the Target Deployment Port Editor, from the File menu, select Open

  3. Open the .xdp file corresponding to the new compiler for which you would like to generate support

  4. In the Target Deployment Port Editor, from the File menu, select Save and Generate

  5. Close the Target Deployment Port Editor