Importing sub-projects

Sub-projects are projects that are grouped together within a master project. Projects can contain one or more sub-projects which are actually links to other project directories. The behaviour of a sub-project is the same as a project.

There are two ways of setting up a master project:

To add an existing sub-project:

  1. Create a new project or open an existing project.

  2. Select File > Add Project > Existing Project. This opens the file selector.

  3. Locate and select an .rtp project file and click OK.

To create a new sub-project:

  1. Create a new project or open an existing project.

  2. Select File > Add Project > New Project. This opens the Add New Project wizard.

  3. Enter a name and location for the new project, and click Finish. The new sub-project is created with the configuration settings of the super-project.

To create a master project containing all sub-projects from a directory:

  1. Close any open projects

  2. Select File > Import > Import multiple OneTest Embedded projects.

  3. Enter the name of the new master project and the location of the existing projects and click OK. The new project is created in the selected directory and imports all the projects found in all sub-directories of that location. When browsing many directories, the import can take a long time.

Related Topics

New Project WizardUnderstanding projects | Working with Projects