Using assembler source files

OneTest Embedded, provides support for using assembler source code in your projects. Due to their nature, you cannot use Component Testing or Runtime Analysis tools directly on assembler files.

Because assembler file extensions are not standard and depend on your development environment, it is necessary to configure OneTest Embedded to recognize the file extension used for assembler files. You must specify the assembler file extension:

To specify the file type preferences:

  1. From the Edit menu, select Preferences and select the Project > Source File Types page.

  2. Click Add to create a new line.

  3. In the Extension column, enter the file extension. For example: *.asm.

  4. In the Description column, enter the description of the file type. For example: Assembler source files.

  5. Click OK.

To change ASMEXT in the TDP Editor:

  1. Open the TDP Editor: from the Tools menu, select Target Deployment Port Editor > Start.

  2. In the TDP Editor select Basic Settings and the native language of the TDP.

  3. Double-click the ASMEXT customization point, and add the assembler file extension. For example: asm.

  4. Save the TDP and quit the TDP Editor.

To add the assembler files to your project.

  1. In the Project explorer, right click an test or application node and select Add Child > Files.

  2. Select the corresponding file type; and locate and select the assembler files that you want to use in your project.

  3. Click OK.

Related Topics

Project PreferencesUsing shared librariesUsing the TDP Editor